We're here to help!

Oracle EXP Compatibility Matrix

Follow
Problem Description

From time to time we receive tickets that customers are having instantiation issues using legacy 'exp'.Oracle Support Note: Doc ID 132904.1 has the entire matrix

Solution
  1. Whenever you use expdp to export data, always use the same version Export Data Pump client as the version of the database from which you are taking dump. Although one major version lower of the expdp client is allowed, it is not recommended. For example:
    • If your database version is 11.1.0.6.0 then you can use the expdp tool from either 11g or 10g but it is recommended to use the 11.1.0.6.0 expdp tool.
  2. Whenever you use impdp to import data always use the same version Import Data Pump client as the version of the database to which you are importing dump. Although one major version lower of the impdp client is allowed, it is not recommended. For example:
    • If your database version is 11.1.0.6.0 then you can use impdp tool from either 11g or 10g but it is recommended to use 11.1.0.6.0 the impdp tool.
  3. Import Data Pump (impdp) can always read Export Data Pump (expdp) dumpfile sets created by older versions of the database. For example:
    • Export dumpfile sets of database 10.1.0.5 can easily be imported into database version 11.1.0.6.
  4. If you decide dumpfiles need to be imported into a lower version database then use the VERSION Export Data Pump parameter. Match the compatibility level of the database to the one which you will import. For example, to import dumpfile sets to a 10.2.0.1 database (where compatibility is set to 10.2.0.1) from an 11.1.0.6 database (where compatibility is set to 11.1.0.0):
    • Append the VERSION parameter to the data pump export client command. For example, if the value of VERSION needs to be 10.2, append VERSION=10.2 as a whole to your expdp command.

Donna Zehl October 22, 2014 07:10

Have more questions? Submit a request

Comments