Post

2 followers Follow
0
Avatar

Upgrading from Standby V7 to V8 - Do I have to use SSH?

I have just gone through the Upgrade steps on our Linux boxes and install V8 on both. I have started dbvagent on both machines but the system seems to be trying to use SSH to connect. Normally when this happens I would just make sure dbvnet was running on both machines and it would use your connection methods and it would work. 

I have checked both machines with ./dbvagent -d status and ./dbvnet -d status and both say the agents are running and gives me the pid numbers.

I have applied the new licence key to the primary server.

If I run the following dbvctl -d LIVE -c on the Primary server I get:

Dbvisit Standby Database Technology message from ekifsrac1

 

Message received from process: dbvctl -d LIVE -c

 

(Dbvisit Standby: 8.0.04.18184 Process id: 27318)

 

201611281348 - Connection to ekifsrac2 failed.

No initial contact can be made or remote command cannot be run Please check network connection and review the settings:

                RSH=

                DEST_SERVER=ekifsrac2

                NETPORT=7890

                DBVISIT_BASE=/usr/dbvisit

 

Error connect: Connection refused

 

Same message if I do a dbvctl -d LIVE -i

I get the same message.

Basically any command I use and the systems try to communicate with each other fail with the above error.

Looking at the CP & RSH parameters in the env file shows them both as blank to use the default dbvnet.

Any suggestion as to what is wrong with my setup. I will upload the trc file when I can

Many thanks.

Regards

Richard Chambers

Richard Chambers Answered

Official comment

Avatar

This has been reported as BUG and will be fixed in Next Release (8.0.06)

Vijayganesh Sivaprakasam
Comment actions Permalink

Please sign in to leave a comment.

2 comments

0
Avatar

If I run ./dbvnet-tool -s ekifsrac2 on the primary server I get a return code of 20 - connection refused. 

The same if I run it on the standby server trying to connect to the primary. Both are using the same port number 7890.

I have still to check with our Linux guys to make sure the port is not being blocked by the firewall.

Regards

Richard Chambers

Richard Chambers 0 votes
Comment actions Permalink