Post

3 followers Follow
0
Avatar

version `GLIBC_2.14' not found (required by ./install-dbvisit)

We are trying to install DBVIST Standby on our linux machines and getting this error

./install-dbvisit: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by ./install-dbvisit)

Can you please explain how to fix this and proceed with the installation 

 

Thanks

Kamran Irshad Answered

Official comment

Avatar
Environment summary :
 uname -r

3.8.13-55.1.5.el6uek.x86_64

more /etc/redhat-release

Red Hat Enterprise Linux Server release 6.6 (Santiago)

 
Steps: 
1. Customer downloaded dbvisit-standby7.0.44-el7.zip which is for RHEL/OEL version 7.
    Ensure to download dbvisit-standby7.0.64-el6.zip which is the correct file for your platform running version 6.
 

2. When you try to install, the following known error will occur, because glibc.i686 not being installed on OEL6 or RHEL

./install-dbvisit 
-bash: ./install-dbvisit: /lib/ld-linux.so.2: bad ELF interpreter: No such file or directory

 3. Get the output of > yum list glibc (available packages)

Loaded plugins: refresh-packagekit, security 
Installed Packages 
glibc.x86_64 2.12-1.149.el6_6.5 @public_ol6_latest 
Available Packages 
glibc.i686 2.12-1.192.el6 public_ol6_latest 
glibc.x86_64 2.12-1.192.el6 public_ol6_latest

 4.  Install the following packages

yum install glibc.i686 
yum install openssl-devel.i686

Charmaigne Bezuidenhout
Comment actions Permalink

Please sign in to leave a comment.

1 comment